Firefox no longer compatible with SharePoint 2013 after latest update (52)

A quick note for those who use Firefox as their default browser of choice, Firefox’s latest release (52.00) is no longer compatible with SharePoint. This is due to Firefox removing any support for addons not coded in Flash, the effect of this is that the Office plugins used primarily to create new documents in SharePoint is no longer able to run meaning you’ll run into errors if you try to create new documents using Firefox.

Continue reading “Firefox no longer compatible with SharePoint 2013 after latest update (52)”